路由配置实验报告

路由配置实验报告

郭高旭 ggx21@mails.tsinghua.edu.cn 2021010803

1. 实验目的

利用OSPF+BGP实现一个较为复杂的网络拓扑

2. 实验环境

3. 实验内容

如图所示

image-20240308182300091

4. 实验步骤

各路由器配置如下.

4.1先配置好AS1中的ospf

以R5为例,观察路径要求可知,R5下一跳应该选择R6,所以我们可以把R5和R8之间的ospf cost调大

1
2
3
4
5
6
7
8
9
10
11
12
R5>enable
R5#configure
R5(config)#interface Ethernet3
R5(config-if-Et3)#ip ospf cost 100
R5(config-if-Et3)#exit
R5(config)#router ospf 1
R5(config-router-ospf)#network 10.1.5.5/32 area 0.0.0.0
R5(config-router-ospf)#network 10.1.8.5/32 area 0.0.0.0
R5(config-router-ospf)#redistribute connected
R5(config-router-ospf)#exit
R5(config)#exit
R5#exit
1
2
3
4
5
6
7
8
9
10
enable
configure
interface Ethernet3
ip ospf cost 100
exit
router ospf 1
network 10.1.5.5/32 area 0.0.0.0
network 10.1.8.5/32 area 0.0.0.0
redistribute connected
exit

r6

1
2
3
4
5
6
7
8
9
10
11
en
config
interface Ethernet3
ip ospf cost 100
interface Ethernet1
ip ospf cost 100
router ospf 1
network 10.1.5.6/32 area 0.0.0.0
network 10.1.6.6/32 area 0.0.0.0
network 10.1.9.6/32 area 0.0.0.0
redistribute connected

r7

1
2
3
4
5
6
7
8
9
enable
configure
interface Ethernet3
ip ospf cost 100
exit
router ospf 1
network 10.1.7.7/32 area 0.0.0.0
network 10.1.6.7/32 area 0.0.0.0
redistribute connected

r8

1
2
3
4
5
6
7
en
config
router ospf 1
network 10.1.8.8/32 area 0.0.0.0
network 10.1.7.8/32 area 0.0.0.0
network 10.1.9.8/32 area 0.0.0.0
redistribute connected

配置好ospf后r5的route table

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Gateway of last resort is not set

C 5.5.5.0/24 is directly connected, Loopback0
O E2 6.6.6.0/24 [110/1] via 10.1.5.6, Ethernet2
O E2 7.7.7.0/24 [110/1] via 10.1.5.6, Ethernet2
O E2 8.8.8.0/24 [110/1] via 10.1.5.6, Ethernet2
C 10.1.1.0/24 is directly connected, Ethernet1
O E2 10.1.2.0/24 [110/1] via 10.1.5.6, Ethernet2
O E2 10.1.3.0/24 [110/1] via 10.1.5.6, Ethernet2
O E2 10.1.4.0/24 [110/1] via 10.1.5.6, Ethernet2
C 10.1.5.0/24 is directly connected, Ethernet2
O 10.1.6.0/24 [110/20] via 10.1.5.6, Ethernet2
O 10.1.7.0/24 [110/30] via 10.1.5.6, Ethernet2
C 10.1.8.0/24 is directly connected, Ethernet3
O 10.1.9.0/24 [110/20] via 10.1.5.6, Ethernet2

除了还没有到其他as的route之外,配置是合理的

4.2配置bgp

r1

1
2
3
4
5
6
enable
config
router bgp 1
router-id 1.1.1.1
neighbor 10.1.1.5 remote-as 5
redistribute connected

r5

1
2
3
4
5
6
enable
config
router bgp 5
router-id 5.5.5.5
neighbor 10.1.1.1 remote-as 1
redistribute connected

r2

1
2
3
4
5
6
enable
config
router bgp 2
router-id 2.2.2.2
neighbor 10.1.2.6 remote-as 6
redistribute connected

r6

1
2
3
4
5
6
enable
config
router bgp 6
router-id 6.6.6.6
neighbor 10.1.2.2 remote-as 2
redistribute connected

r3

1
2
3
4
5
6
enable
config
router bgp 3
router-id 3.3.3.3
neighbor 10.1.3.7 remote-as 7
redistribute connected

r7

1
2
3
4
5
6
enable
config
router bgp 7
router-id 7.7.7.7
neighbor 10.1.3.3 remote-as 3
redistribute connected

r4

1
2
3
4
5
6
enable
config
router bgp 4
router-id 4.4.4.4
neighbor 10.1.4.8 remote-as 8
redistribute connected

r8

1
2
3
4
5
6
enable
config
router bgp 8
router-id 8.8.8.8
neighbor 10.1.4.4 remote-as 4
redistribute connected

现在R1知道了R5直接相连的网段,R5也新增了到R1的路由,显示确实是用BGP学到的。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
R5(config-router-bgp)#show ip route
B E 1.1.1.0/24 [200/0] via 10.1.1.1, Ethernet1 <------------bgp
C 5.5.5.0/24 is directly connected, Loopback0
O E2 6.6.6.0/24 [110/1] via 10.1.5.6, Ethernet2
O E2 7.7.7.0/24 [110/1] via 10.1.5.6, Ethernet2
O E2 8.8.8.0/24 [110/1] via 10.1.5.6, Ethernet2
C 10.1.1.0/24 is directly connected, Ethernet1
O E2 10.1.2.0/24 [110/1] via 10.1.5.6, Ethernet2
O E2 10.1.3.0/24 [110/1] via 10.1.5.6, Ethernet2
O E2 10.1.4.0/24 [110/1] via 10.1.5.6, Ethernet2
C 10.1.5.0/24 is directly connected, Ethernet2
O 10.1.6.0/24 [110/20] via 10.1.5.6, Ethernet2
O 10.1.7.0/24 [110/30] via 10.1.5.6, Ethernet2
C 10.1.8.0/24 is directly connected, Ethernet3
O 10.1.9.0/24 [110/20] via 10.1.5.6, Ethernet2

4.3 redistribute BGP and redistribute OSPF

剩下的问题在于bgp和ospf默认情况下不会redistribute另一个协议学习到的路由。在R5~R8手动redistribute即可。

r5(6/7/8)

1
2
3
4
5
router bgp 8
redistribute OSPF match internal
redistribute OSPF match external
router ospf 1
redistribute BGP

5. 实验结果

成功通过测试

1
2
3
4
5
6
7
8
9
10
11
12
13
./test.py
R1 -> R1: True R2: True R3: True R4: True R5: True R6: True R7: True R8: True
R2 -> R1: True R2: True R3: True R4: True R5: True R6: True R7: True R8: True
R3 -> R1: True R2: True R3: True R4: True R5: True R6: True R7: True R8: True
R4 -> R1: True R2: True R3: True R4: True R5: True R6: True R7: True R8: True
R5 -> R1: True R2: True R3: True R4: True R5: True R6: True R7: True R8: True
R6 -> R1: True R2: True R3: True R4: True R5: True R6: True R7: True R8: True
R7 -> R1: True R2: True R3: True R4: True R5: True R6: True R7: True R8: True
R8 -> R1: True R2: True R3: True R4: True R5: True R6: True R7: True R8: True
Pass Connectivity Test
Path R1 -> R3: 1 -> 5 -> 6 -> 8 -> 7 -> 3
Path R3 -> R1: 3 -> 7 -> 6 -> 8 -> 5 -> 1
Pass Path Test

6. 实验分析

跟着lab1和lab2做完之后,lab3比较容易就可以做出来,实验指导比较合理。

实验做了十分钟,环境配置花了一整天。也不是环境配置麻烦,主要是需要安装Vmware。也不是安装Vmware麻烦,主要是虚拟机写了一半崩溃了再也打不开。也不是崩溃了就不能写了,主要是wsl环境配置相比虚拟机完全不一样。也不是wsl环境下配置麻烦多少,主要是wsl跑了半天也崩溃了。wsl崩溃了就崩溃了吧,主要是我为了处理崩溃一顿配置让我的wsl再也打不开了。也不是打不开就不能写了,主要是重装完wsl又得配一遍环境。想到我其他课的环境也得重新配一遍,我感觉感冒好多了。

7. 实验总结

通过这次实验,我熟悉了ospf和bgp的基本工作原理,掌握了路由配置的一些基本方法。

8. 参考文献

  • 实验指导

  • RFC 4271

  • RFC 2328




本文总阅读量